What’s Vulnerable › Vulnerabilities
CVE-2024-51492: Zusam vulnerable to stored XSS, allowing token theft via crafted SVG
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Zusam is a free and open-source way to self-host private forums. Prior to version 0.5.6, specially crafted SVG files uploaded to the service as images allow for unrestricted script execution on (raw) image load. With certain payloads, theft of the target user’s long-lived session token is possible. Note that Zusam, at the time of writing, uses a user’s static API key as a long-lived session token, and these terms can be used interchangeably on the platform. This session token/API key remains valid indefinitely, so long as the user doesn’t expressly request a new one via their Settings page. Version 0.5.6 fixes the cross-site scripting vulnerability.
Affected products
- zusam: before 0.5.6 — fixed in 0.5.6
How to fix
Upgrade to a fixed version: zusam 0.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/zusam/zusam/commit/5930fdf86fa4abed01f0b345c8ec3c443656db9a
- https://github.com/zusam/zusam/releases/tag/0.5.6
- https://github.com/zusam/zusam/security/advisories/GHSA-96fx-5rqv-jfxh
- https://pfeister.dev/CVE-2024-51492
Get alerted when CVE-2024-51492 or the next vulnerability affects your stack