What’s Vulnerable › Vulnerabilities
CVE-2024-51497: LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/includes/html/print-customoid.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Custom OID" tab of a device allows authenticated users to inject arbitrary JavaScript through the "unit" parameter when creating a new OID. This vulnerability can lead to the execution of malicious code in the context of other users' sessions, compromising their accounts and enabling unauthorized actions. This vulnerability is fixed in 24.10.0.
Affected products
- librenms: before 24.10.0 — fixed in 24.10.0
How to fix
Upgrade to a fixed version: librenms 24.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/42b156e42a3811c23758772ce8c63d4d3eaba59b
- https://github.com/librenms/librenms/security/advisories/GHSA-gv4m-f6fx-859x
Get alerted when CVE-2024-51497 or the next vulnerability affects your stack