What’s Vulnerable › Vulnerabilities
CVE-2024-51540
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-26 · updated 2026-06-17
- Weakness: CWE-190
Description
Dell ECS, versions prior to 3.8.1.3 contains an arithmetic overflow vulnerability exists in retention period handling of ECS. An authenticated user with bucket or object-level access and the necessary privileges could potentially exploit this vulnerability to bypass retention policies and delete objects.
Affected products
- EMC Elastic Cloud Storage all versions prior to 3.1: before 3.8.1.3 — fixed in 3.8.1.3
How to fix
Upgrade to a fixed version: EMC Elastic Cloud Storage all versions prior to 3.1 3.8.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51540 or the next vulnerability affects your stack