What’s Vulnerable › Vulnerabilities
CVE-2024-51557: No Rate Limiting Vulnerability in Wave 2.0
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-799
Description
This vulnerability exists in the Wave 2.0 due to missing rate limiting on OTP requests in an API endpoint. An authenticated remote attacker could exploit this vulnerability by sending multiple OTP request through vulnerable API endpoint which could lead to the OTP bombing/flooding on the targeted system.
Affected products
- Brokerage Technology Solutions Aero: before 120820241550 — fixed in 120820241550
- Brokerage Technology Solutions Wave 2.0: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: Brokerage Technology Solutions Aero 120820241550; Brokerage Technology Solutions Wave 2.0 1.1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51557 or the next vulnerability affects your stack