What’s Vulnerable › Vulnerabilities
CVE-2024-51567: CyberPanel Incorrect Default Permissions Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-11-07
- EPSS: 84.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-29 · updated 2026-08-04
- Weakness: CWE-306
Description
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
Affected products
- usmannasir cyberpanel: before 2.3.8 — fixed in 2.3.8
How to fix
Upgrade to a fixed version: usmannasir cyberpanel 2.3.8. Check the vendor advisory for mitigations.
References
- https://cwe.mitre.org/data/definitions/420.html
- https://cwe.mitre.org/data/definitions/78.html
- https://cyberpanel.net/KnowledgeBase/home/change-logs/
- https://cyberpanel.net/blog/detials-and-fix-of-recent-security-issue-and-patch-of-cyberpanel
- https://dreyand.rs/code/review/2024/10/27/what-are-my-options-cyberpanel-v236-pre-auth-rce
- https://github.com/usmannasir/cyberpanel/commit/5b08cd6d53f4dbc2107ad9f555122ce8b0996515
- https://www.bleepingcomputer.com/news/security/massive-psaux-ransomware-attack-targets-22-000-cyberpanel-instances/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-51567
Get alerted when CVE-2024-51567 or the next vulnerability affects your stack