What’s Vulnerable › Vulnerabilities
CVE-2024-5161: Magical Addons For Elementor <= 1.1.39 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘_id’ parameter in all versions up to, and including, 1.1.39 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ): before 1.1.40 — fixed in 1.1.40
How to fix
Upgrade to a fixed version: nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ) 1.1.40. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/magical-addons-for-elementor/trunk/includes/widgets/advance-skill-bars.php#L502
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3098054%40magical-addons-for-elementor&new=3098054%40magical-addons-for-elementor&sfp_email=&sfph_mail=#file9
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cb64952e-170e-47c5-87fd-d2ec60192b65?source=cve
- https://plugins.trac.wordpress.org/browser/magical-addons-for-elementor/trunk/includes/widgets/advance-skill-bars.php#L502
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3098054%40magical-addons-for-elementor&new=3098054%40magical-addons-for-elementor&sfp_email=&sfph_mail=#file9
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cb64952e-170e-47c5-87fd-d2ec60192b65?source=cve
Get alerted when CVE-2024-5161 or the next vulnerability affects your stack