What’s Vulnerable › Vulnerabilities
CVE-2024-51665: WordPress Magical Addons For Elementor plugin <= 1.2.1 - Server Side Request Forgery (SSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Noor Alam Magical Addons For Elementor magical-addons-for-elementor allows Server Side Request Forgery.This issue affects Magical Addons For Elementor: from n/a through <= 1.2.1.
Affected products
- nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ): before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ) 1.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51665 or the next vulnerability affects your stack