What’s Vulnerable › Vulnerabilities
CVE-2024-51670: WordPress JS Help Desk plugin <= 2.8.7 - Stored Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in JoomSky JS Help Desk js-support-ticket allows Stored XSS.This issue affects JS Help Desk: from n/a through <= 2.8.7.
Affected products
- JoomSky JS Help Desk: before 2.8.8 — fixed in 2.8.8
How to fix
Upgrade to a fixed version: JoomSky JS Help Desk 2.8.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51670 or the next vulnerability affects your stack