What’s Vulnerable › Vulnerabilities
CVE-2024-51672: WordPress BetterLinks plugin <= 2.1.7 - SQL Injection vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPDeveloper BetterLinks betterlinks allows SQL Injection.This issue affects BetterLinks: from n/a through <= 2.1.7.
Affected products
- WPDeveloper BetterLinks: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: WPDeveloper BetterLinks 2.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51672 or the next vulnerability affects your stack