What’s Vulnerable › Vulnerabilities
CVE-2024-51678: WordPress Elo Rating Shortcode plugin <= 1.0.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Marcel Pol Elo Rating Shortcode elo-rating-shortcode allows Stored XSS.This issue affects Elo Rating Shortcode: from n/a through <= 1.0.3.
Affected products
- Marcel Pol Elo Rating Shortcode: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Marcel Pol Elo Rating Shortcode 1.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51678 or the next vulnerability affects your stack