What’s Vulnerable › Vulnerabilities
CVE-2024-51682: WordPress HT Builder – WordPress Theme Builder for Elementor plugin <= 1.3.0 - Stored Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HasThemes HT Builder – WordPress Theme Builder for Elementor ht-builder allows Stored XSS.This issue affects HT Builder – WordPress Theme Builder for Elementor: from n/a through <= 1.3.0.
Affected products
- HasThemes HT Builder – WordPress Theme Builder for Elementor: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: HasThemes HT Builder – WordPress Theme Builder for Elementor 1.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51682 or the next vulnerability affects your stack