What’s Vulnerable › Vulnerabilities
CVE-2024-51683: WordPress Custom post type templates for Elementor plugin <= 1.10.1 - Stored Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Michael Custom post type templates for Elementor custom-post-type-templates-for-elementor allows Stored XSS.This issue affects Custom post type templates for Elementor: from n/a through <= 1.10.1.
Affected products
- Michael Custom post type templates for Elementor: before 1.1.12 — fixed in 1.1.12
How to fix
Upgrade to a fixed version: Michael Custom post type templates for Elementor 1.1.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51683 or the next vulnerability affects your stack