What’s Vulnerable › Vulnerabilities
CVE-2024-51715: WordPress ClickWhale plugin <= 2.4.1 - SQL Injection vulnerability
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ClickWhale ClickWhale clickwhale allows Blind SQL Injection.This issue affects ClickWhale: from n/a through <= 2.4.1.
Affected products
- ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages 2.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51715 or the next vulnerability affects your stack