What’s Vulnerable › Vulnerabilities
CVE-2024-51736: Command execution hijack on Windows with Process class in symfony/process
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-77
Description
Symphony process is a module for the Symphony PHP framework which executes commands in sub-processes. On Windows, when an executable file named `cmd.exe` is located in the current working directory it will be called by the `Process` class when preparing command arguments, leading to possible hijacking. This issue has been addressed in release versions 5.4.46, 6.4.14, and 7.1.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- symfony: before 5.4.46; from 6.0.0 before 6.4.14; from 7.0.0 before 7.1.7 — fixed in 5.4.46, 6.4.14, 7.1.7
- Packagist Symfony/Process: before 5.4.46; from 6.0.0 before 6.4.14; from 7.0.0 before 7.1.7; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.12 (+550) — fixed in 5.4.46, 6.4.14, 7.1.7
- Packagist Symfony/Symfony: before 5.4.46; from 6.0.0 before 6.4.14; from 7.0.0 before 7.1.7; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.11 (+608) — fixed in 5.4.46, 6.4.14, 7.1.7
How to fix
Upgrade to a fixed version: symfony 5.4.46, 6.4.14, 7.1.7; Packagist Symfony/Process 5.4.46, 6.4.14, 7.1.7; Packagist Symfony/Symfony 5.4.46, 6.4.14, 7.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/security/advisories/GHSA-qq5c-677p-737q
- https://github.com/symfony/symfony/security/advisories/GHSA-qq5c-677p-737q
- https://github.com/symfony/symfony/security/advisories/GHSA-qq5c-677p-737q
- https://github.com/symfony/symfony/security/advisories/GHSA-qq5c-677p-737q
Get alerted when CVE-2024-51736 or the next vulnerability affects your stack