What’s Vulnerable › Vulnerabilities
CVE-2024-51741: Redis allows denial-of-service due to malformed ACL selectors
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-20
Description
Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem is fixed in Redis 7.2.7 and 7.4.2.
Affected products
- Redis: from 7.0.0 before 7.2.7; from 7.4.0 before 7.4.2 — fixed in 7.2.7, 7.4.2
How to fix
Upgrade to a fixed version: Redis 7.2.7, 7.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51741 or the next vulnerability affects your stack