What’s Vulnerable › Vulnerabilities
CVE-2024-51774
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-02 · updated 2026-06-17
- Weakness: CWE-295
Description
qBittorrent before 5.0.1 proceeds with use of https URLs even after certificate validation errors.
Affected products
- qBittorrent client: before 5.0.1 — fixed in 5.0.1
How to fix
Upgrade to a fixed version: qBittorrent client 5.0.1. Check the vendor advisory for mitigations.
References
- https://news.ycombinator.com/item?id=42004219
- https://sharpsec.run/rce-vulnerability-in-qbittorrent/
- https://www.qbittorrent.org/news
Get alerted when CVE-2024-51774 or the next vulnerability affects your stack