What’s Vulnerable › Vulnerabilities
CVE-2024-51775: Apache Zeppelin: Command Injection via CSWSH
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-03 · updated 2026-06-17
- Weakness: CWE-1385
Description
Missing Origin Validation in WebSockets vulnerability in Apache Zeppelin. The attacker could access the Zeppelin server from another origin without any restriction, and get internal information about paragraphs. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.11.0 before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51775 or the next vulnerability affects your stack