What’s Vulnerable › Vulnerabilities
CVE-2024-51787: WordPress ElementsReady Addons for Elementor plugin <= 6.4.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in quomodosoft ElementsReady Addons for Elementor element-ready-lite allows Stored XSS.This issue affects ElementsReady Addons for Elementor: from n/a through <= 6.4.3.
Affected products
- quomodosoft ElementsReady Addons for Elementor: before 6.4.4 — fixed in 6.4.4
How to fix
Upgrade to a fixed version: quomodosoft ElementsReady Addons for Elementor 6.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51787 or the next vulnerability affects your stack