What’s Vulnerable › Vulnerabilities
CVE-2024-5197: Integer overflow in libvpx
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-190
Description
There exists interger overflows in libvpx in versions prior to 1.14.1. Calling vpx_img_alloc() with a large value of the d_w, d_h, or align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. Calling vpx_img_wrap() with a large value of the d_w, d_h, or stride_align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. We recommend upgrading to version 1.14.1 or beyond
Affected products
- Debian Linux: 10.0
- Chromium libvpx: before 1.14.1 — fixed in 1.14.1
How to fix
Upgrade to a fixed version: Chromium libvpx 1.14.1. Check the vendor advisory for mitigations.
References
- https://g-issues.chromium.org/issues/332382766
- https://lists.debian.org/debian-lts-announce/2024/06/msg00005.html
- https://g-issues.chromium.org/issues/332382766
- https://lists.debian.org/debian-lts-announce/2024/06/msg00005.html
Get alerted when CVE-2024-5197 or the next vulnerability affects your stack