What’s Vulnerable › Vulnerabilities
CVE-2024-52000: Reflected Cross-site Scripting exploit in Combodo iTop
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Combodo iTop is a simple, web based IT Service Management tool. Affected versions are subject to a reflected Cross-site Scripting (XSS) exploit by way of editing a request's payload which can lead to malicious javascript execution. This issue has been addressed in version 3.2.0 via systematic escaping of error messages when rendering on the page. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Combodo iTop: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Combodo iTop 3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52000 or the next vulnerability affects your stack