What’s Vulnerable › Vulnerabilities
CVE-2024-52004: Remote code execution vulnerabilities in MediaCMS
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-74
Description
MediaCMS is an open source video and media CMS, written in Python/Django and React, featuring a REST API. MediaCMS has been prone to vulnerabilities that upon special cases can lead to remote code execution. All versions before v4.1.0 are susceptible, and users are highly recommended to upgrade. The vulnerabilities are related with insufficient input validation while uploading media content. The condition to exploit the vulnerability is that the portal allows users to upload content. This issue has been patched in version 4.1.0. There are no known workarounds for this vulnerability.
Affected products
- MediaCMS: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: MediaCMS 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/mediacms-io/mediacms/blob/main/docs/admins_docs.md
- https://github.com/mediacms-io/mediacms/security/advisories/GHSA-x3p4-4442-q2c3
Get alerted when CVE-2024-52004 or the next vulnerability affects your stack