What’s Vulnerable › Vulnerabilities
CVE-2024-52007: XXE vulnerability in XSLT parsing in `org.hl7.fhir.core`
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-611
Description
HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. XSLT parsing performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( <!DOCTYPE foo [<!ENTITY example SYSTEM "/etc/passwd"> ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.core is being used to within a host where external clients can submit XML. This is related to GHSA-6cr6-ph3p-f5rf, in which its fix (#1571 & #1717) was incomplete. This issue has been addressed in release version 6.4.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- hapifhir org.hl7.fhir.core: before 6.4.0 — fixed in 6.4.0
How to fix
Upgrade to a fixed version: hapifhir org.hl7.fhir.core 6.4.0. Check the vendor advisory for mitigations.
References
- https://cheatsheetseries.owasp.org/cheatsheets/XML_External_Entity_Prevention_Cheat_Sheet.html#jaxp-documentbuilderfactory-saxparserfactory-and-dom4j
- https://cwe.mitre.org/data/definitions/611.html
- https://github.com/hapifhir/org.hl7.fhir.core/issues/1571
- https://github.com/hapifhir/org.hl7.fhir.core/pull/1717
- https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-6cr6-ph3p-f5rf
- https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-gr3c-q7xf-47vh
Get alerted when CVE-2024-52007 or the next vulnerability affects your stack