What’s Vulnerable › Vulnerabilities
CVE-2024-52012: Apache Solr: Configset upload on Windows allows arbitrary path write-access
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 40.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-23
Description
Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API. Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue. Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.
Affected products
- Apache Software Foundation Apache Solr: from 6.6.0 before 9.8.0 — fixed in 9.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Solr 9.8.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yp39pgbv4vf1746pf5yblz84lv30vfxd
- http://www.openwall.com/lists/oss-security/2025/01/26/2
Get alerted when CVE-2024-52012 or the next vulnerability affects your stack