What’s Vulnerable › Vulnerabilities
CVE-2024-52065: Potential stack buffer write overflow in Persistence Service while parsing malicious environment variable on non-Windows systems
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in RTI Connext Professional on non-Windows (Persistence Service) allows Buffer Overflow via Environment Variables.This issue affects Connext Professional: from 7.0.0 before 7.3.0.2, from 6.1.1.2 before 6.1.2.21, from 5.3.1.40 before 5.3.1.41.
Affected products
- RTI Connext Professional: from 6.1.1.2 before 6.1.2.21; from 7.0.0 before 7.3.0.2; 5.3.1.40 — fixed in 6.1.2.21, 7.3.0.2
How to fix
Upgrade to a fixed version: RTI Connext Professional 6.1.2.21, 7.3.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52065 or the next vulnerability affects your stack