What’s Vulnerable › Vulnerabilities
CVE-2024-5220: ND Shortcodes <= 7.5 - Authenticated (Author+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The ND Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's upload feature in all versions up to, and including, 7.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- ND Shortcodes: before 7.6 — fixed in 7.6
How to fix
Upgrade to a fixed version: ND Shortcodes 7.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/nd-shortcodes/tags/7.3/nd-shortcodes.php#L63
- https://plugins.trac.wordpress.org/changeset/3091778/nd-shortcodes/trunk/nd-shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5cbd6040-0446-41fe-8fef-c9065beeaa3a?source=cve
- https://plugins.trac.wordpress.org/browser/nd-shortcodes/tags/7.3/nd-shortcodes.php#L63
- https://plugins.trac.wordpress.org/changeset/3091778/nd-shortcodes/trunk/nd-shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5cbd6040-0446-41fe-8fef-c9065beeaa3a?source=cve
Get alerted when CVE-2024-5220 or the next vulnerability affects your stack