What’s Vulnerable › Vulnerabilities
CVE-2024-5226: Fuse Social Floating Sidebar <= 5.4.10 - Authenticated (Author+) Stored Cross-Site Scripting via File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Fuse Social Floating Sidebar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the file upload functionality in all versions up to, and including, 5.4.10 due to insufficient validation of SVG files. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- daniyalahmedk Fuse Social Floating Sidebar: before 5.4.11 — fixed in 5.4.11
How to fix
Upgrade to a fixed version: daniyalahmedk Fuse Social Floating Sidebar 5.4.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fuse-social-floating-sidebar/tags/5.4.10/framework/redux-core/inc/extensions/custom_fonts/class-redux-extension-custom-fonts.php#L126
- https://plugins.trac.wordpress.org/changeset/3131828/
- https://wordpress.org/plugins/fuse-social-floating-sidebar/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1a3137a1-8e46-44c6-8edd-ad9fc4d66e0b?source=cve
Get alerted when CVE-2024-5226 or the next vulnerability affects your stack