What’s Vulnerable › Vulnerabilities
CVE-2024-52279: Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-03 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.11.1 before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/zeppelin/pull/4838
- https://issues.apache.org/jira/browse/ZEPPELIN-6095
- https://lists.apache.org/thread/dxb98vgrb21rrl3k0fzonpk66onr6o4q
- https://www.cve.org/CVERecord?id=CVE-2024-31864
- http://www.openwall.com/lists/oss-security/2025/08/03/3
Get alerted when CVE-2024-52279 or the next vulnerability affects your stack