What’s Vulnerable › Vulnerabilities
CVE-2024-52281: Stored Cross-site Scripting vulnerability in Rancher UI
- Severity: high (CVSS 8.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
A: Improper Neutralization of Input During Web Page Generation vulnerability in SUSE rancher allows a malicious actor to perform a Stored XSS attack through the cluster description field. This issue affects rancher: from 2.9.0 before 2.9.4.
Affected products
- SUSE Rancher: from 2.9.0 before 2.9.4 — fixed in 2.9.4
How to fix
Upgrade to a fixed version: SUSE Rancher 2.9.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-52281
- https://github.com/rancher/rancher/security/advisories/GHSA-2v2w-8v8c-wcm9
Get alerted when CVE-2024-52281 or the next vulnerability affects your stack