What’s Vulnerable › Vulnerabilities
CVE-2024-52282: Rancher Helm Applications may have sensitive values leaked
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-200
Description
A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowing any users with GET access to the Rancher Manager Apps Catalog to read any sensitive information that are contained within the Apps’ values. Additionally, the same information leaks into auditing logs when the audit level is set to equal or above 2. This issue affects rancher: from 2.8.0 before 2.8.10, from 2.9.0 before 2.9.4.
Affected products
- SUSE Rancher: from 2.8.0 before 2.8.10; from 2.9.0 before 2.9.4 — fixed in 2.8.10, 2.9.4
How to fix
Upgrade to a fixed version: SUSE Rancher 2.8.10, 2.9.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-52282
- https://github.com/rancher/rancher/security/advisories/GHSA-9c5p-35gj-jqp4
Get alerted when CVE-2024-52282 or the next vulnerability affects your stack