What’s Vulnerable › Vulnerabilities
CVE-2024-52287: authentik performs insufficient validation of OAuth scopes
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-285
Description
authentik is an open-source identity provider. When using the client_credentials or device_code OAuth grants, it was possible for an attacker to get a token from authentik with scopes that haven't been configured in authentik. authentik 2024.8.5 and 2024.10.3 fix this issue.
Affected products
- goauthentik authentik: before 2024.8.5; from 2024.10.0 before 2024.10.3 — fixed in 2024.10.3, 2024.8.5
How to fix
Upgrade to a fixed version: goauthentik authentik 2024.10.3, 2024.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/commit/e9c29e1644e9199b4ba58d2b10eb8c322138eea2
- https://github.com/goauthentik/authentik/security/advisories/GHSA-v6m7-8j37-8f4v
Get alerted when CVE-2024-52287 or the next vulnerability affects your stack