What’s Vulnerable › Vulnerabilities
CVE-2024-5229: Primary Addon for Elementor <= 1.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Pricing Table Widget
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Primary Addon for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Pricing Table widget in all versions up to, and including, 1.5.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- nicheaddons Primary Addon for Elementor: before 1.5.6 — fixed in 1.5.6
How to fix
Upgrade to a fixed version: nicheaddons Primary Addon for Elementor 1.5.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/primary-addon-for-elementor/trunk/elementor/widgets/basic/nabasic-pricing-table.php#L775
- https://plugins.trac.wordpress.org/changeset/3092073/#file366
- https://plugins.trac.wordpress.org/changeset/3092073/primary-addon-for-elementor/trunk/elementor/widgets/basic/nabasic-pricing-table.php
- https://wordpress.org/plugins/primary-addon-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d6ea95b5-9e1c-41b1-9bc5-5fd5cecef65d?source=cve
- https://plugins.trac.wordpress.org/browser/primary-addon-for-elementor/trunk/elementor/widgets/basic/nabasic-pricing-table.php#L775
- https://plugins.trac.wordpress.org/changeset/3092073/#file366
- https://plugins.trac.wordpress.org/changeset/3092073/primary-addon-for-elementor/trunk/elementor/widgets/basic/nabasic-pricing-table.php
- https://wordpress.org/plugins/primary-addon-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d6ea95b5-9e1c-41b1-9bc5-5fd5cecef65d?source=cve
Get alerted when CVE-2024-5229 or the next vulnerability affects your stack