What’s Vulnerable › Vulnerabilities
CVE-2024-52300: macro-pdfviewer has a XSS through the width parameter
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-80
Description
macro-pdfviewer is a PDF Viewer Macro for XWiki using Mozilla pdf.js. The width parameter of the PDF viewer macro isn't properly escaped, allowing XSS for any user who can edit a page. XSS can impact the confidentiality, integrity and availability of the whole XWiki installation when an admin visits the page with the malicious code. This is fixed in 2.5.6.
Affected products
- xwikisas macro-pdfviewer: before 2.5.6 — fixed in 2.5.6
How to fix
Upgrade to a fixed version: xwikisas macro-pdfviewer 2.5.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52300 or the next vulnerability affects your stack