What’s Vulnerable › Vulnerabilities
CVE-2024-52301: Laravel allows environment manipulation via query string
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 44.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-88
Description
Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, and 11.31.0. The framework now ignores argv values for environment detection on non-cli SAPIs.
Affected products
- Debian Linux: 11.0
- Laravel Framework: before 6.20.45; from 7.0.0 before 7.30.7; from 8.0.0 before 8.83.28; from 9.0.0 before 9.52.17; from 10.0.0 before 10.48.23; from 11.0.0 before 11.31.0 — fixed in 10.48.23, 11.31.0, 6.20.45, 7.30.7, 8.83.28, 9.52.17
- Packagist Laravel/Framework: before 6.20.45; from 7.0.0 before 7.30.7; from 8.0.0 before 8.83.28; from 9.0.0 before 9.52.17; from 10.0.0 before 10.48.23; from 11.0.0 before 11.31.0 — fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, 11.31.0
How to fix
Upgrade to a fixed version: Laravel Framework 10.48.23, 11.31.0, 6.20.45, 7.30.7; Packagist Laravel/Framework 6.20.45, 7.30.7, 8.83.28, 9.52.17. Check the vendor advisory for mitigations.
References
- https://github.com/laravel/framework/security/advisories/GHSA-gv7v-rgg6-548h
- https://lists.debian.org/debian-lts-announce/2024/12/msg00019.html
Get alerted when CVE-2024-52301 or the next vulnerability affects your stack