What’s Vulnerable › Vulnerabilities
CVE-2024-52304: aiohttp vulnerable to request smuggling due to incorrect parsing of chunk extensions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-444
Description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.10.11, the Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or `AIOHTTP_NO_EXTENSIONS` is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.10.11 fixes the issue.
Affected products
- aio-libs aiohttp: before 3.10.11 — fixed in 3.10.11
- Pypi Aiohttp: before 3.10.11; 0.1, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0 (+242) — fixed in 3.10.11
How to fix
Upgrade to a fixed version: aio-libs aiohttp 3.10.11; Pypi Aiohttp 3.10.11. Check the vendor advisory for mitigations.
References
- https://github.com/aio-libs/aiohttp/commit/259edc369075de63e6f3a4eaade058c62af0df71
- https://github.com/aio-libs/aiohttp/security/advisories/GHSA-8495-4g3g-x7pr
- https://lists.debian.org/debian-lts-announce/2025/02/msg00002.html
Get alerted when CVE-2024-52304 or the next vulnerability affects your stack