What’s Vulnerable › Vulnerabilities
CVE-2024-52313: data.all authenticated users can obtain incorrect object level authorizations
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-639
Description
An authenticated data.all user is able to manipulate a getDataset query to fetch additional information regarding the parent Environment resource that the user otherwise would not able to fetch by directly querying the object via getEnvironment in data.all.
Affected products
- amazon data.all: from 1.0.0 before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: amazon data.all 2.6.1. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/AWS-2024-013
- https://github.com/data-dot-all/dataall/releases/tag/v2.6.1
- https://github.com/data-dot-all/dataall/security/advisories/GHSA-hx8q-7wxv-6c7c
Get alerted when CVE-2024-52313 or the next vulnerability affects your stack