What’s Vulnerable › Vulnerabilities

CVE-2024-52316: Apache Tomcat: Authentication bypass when using Jakarta Authentication API

Description

Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.

Summary

Apache Tomcat has an authentication bypass (CVE-2024-52316, CVSS 9.8) where a custom Jakarta Authentication ServerAuthContext that throws an exception without setting an HTTP failure status may not fail authentication, letting users bypass it. Affected versions are 11.0.0-M1 through 11.0.0-M26, 10.1.0-M1 through 10.1.30, 9.0.0-M1 through 9.0.95, and EOL 8.5.0 through 8.5.100. No known components behave this way and exploitation has not been observed (not in CISA KEV, SSVC none, EPSS 6.2%). Upgrade to 11.0.0, 10.1.31, or 9.0.96; Debian users should apply the fixed package.

توجد ثغرة تجاوز للمصادقة في Apache Tomcat تحمل الرقم CVE-2024-52316 ودرجة خطورة 9.8، إذ قد لا تفشل المصادقة عند استخدام مكوّن Jakarta Authentication ServerAuthContext مخصص يرمي استثناءً دون تعيين حالة HTTP للفشل، ما يسمح بتجاوز عملية المصادقة. تشمل الإصدارات المتأثرة 11.0.0-M1 حتى 11.0.0-M26، و10.1.0-M1 حتى 10.1.30، و9.0.0-M1 حتى 9.0.95، إضافة إلى الإصدارات المنتهية الدعم 8.5.0 حتى 8.5.100. لا تُعرف مكوّنات تتصرف بهذه الطريقة، ولم يُرصد استغلال فعلي (غير مدرجة في CISA KEV، وتقييم SSVC هو none، واحتمال EPSS للاستغلال خلال 30 يوماً 6.2%). يُنصح بالترقية إلى 11.0.0 أو 10.1.31 أو 9.0.96، وعلى مستخدمي Debian تطبيق الحزمة المُصححة.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.31, 9.0.96. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-52316 or the next vulnerability affects your stack