What’s Vulnerable › Vulnerabilities
CVE-2024-52332: igb: Fix potential invalid memory access in igb_init_module()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-11 · updated 2026-10-15
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: igb: Fix potential invalid memory access in igb_init_module() The pci_register_driver() can fail and when this happened, the dca_notifier needs to be unregistered, otherwise the dca_notifier can be called when igb fails to install, resulting to invalid memory access.
Affected products
- Linux kernel: from 2.6.30 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.66; from 6.7 before 6.12.5 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.12.5, 6.6.66
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0566f83d206c7a864abcd741fe39d6e0ae5eef29
- https://git.kernel.org/stable/c/4458046617dfadc351162dbaea1945c57eebdf36
- https://git.kernel.org/stable/c/4fe517643f529e805bb6b890a4331c100e8f2484
- https://git.kernel.org/stable/c/8009cdcc493fa30d4572016daf2d6999da4d6c54
- https://git.kernel.org/stable/c/992fd34122de377b45cb75b64fc7f17fc1e6ed2f
- https://git.kernel.org/stable/c/e0155b1b1509d0ef4799bd1cd73309ca466df3f3
- https://git.kernel.org/stable/c/f309733a8c9da7d4266a8a3755020b738a570cae
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
- https://cert-portal.siemens.com/productcert/html/ssa-355557.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2024-52332 or the next vulnerability affects your stack