What’s Vulnerable › Vulnerabilities
CVE-2024-52338: Apache Arrow R package: Arbitrary code execution when loading a malicious data file
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-28 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of untrusted data in IPC and Parquet readers in the Apache Arrow R package versions 4.0.0 through 16.1.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example, user-supplied input files). This vulnerability only affects the arrow R package, not other Apache Arrow implementations or bindings unless those bindings are specifically used via the R package (for example, an R application that embeds a Python interpreter and uses PyArrow to read files from untrusted sources is still vulnerable if the arrow R package is an affected version). It is recommended that users of the arrow R package upgrade to 17.0.0 or later. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to arrow 17.0.0 or later. If using an affected version of the package, untrusted data can read into a Table and its internal to_data_frame() method can be used as a workaround (e.g., read_parquet(..., as_data_frame = FALSE)$to_data_frame()). This issue affects the Apache Arrow R package: from 4.0.0 through 16.1.0. Users are recommended to upgrade to version 17.0.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Arrow: from 4.0.0 before 17.0.0 — fixed in 17.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Arrow 17.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/arrow/commit/801de2fbcf5bcbce0c019ed4b35ff3fc863b141b
- https://lists.apache.org/thread/0rcbvj1gdp15lvm23zm601tjpq0k25vt
- http://www.openwall.com/lists/oss-security/2024/11/28/3
Get alerted when CVE-2024-52338 or the next vulnerability affects your stack