What’s Vulnerable › Vulnerabilities
CVE-2024-52354: WordPress Web Stories Widgets For Elementor plugin <= 1.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Cool Plugins Web Stories Widgets For Elementor shortcodes-for-amp-web-stories-and-elementor-widget allows Stored XSS.This issue affects Web Stories Widgets For Elementor: from n/a through <= 1.1.
Affected products
- Cool Plugins Web Stories Widgets For Elementor: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: Cool Plugins Web Stories Widgets For Elementor 1.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52354 or the next vulnerability affects your stack