What’s Vulnerable › Vulnerabilities
CVE-2024-52355: WordPress OSM – OpenStreetMap plugin <= 6.1.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MiKa OSM osm.This issue affects OSM: from n/a through <= 6.1.2.
Affected products
- photoweblog OSM – OpenStreetMap: before 6.1.3 — fixed in 6.1.3
How to fix
Upgrade to a fixed version: photoweblog OSM – OpenStreetMap 6.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52355 or the next vulnerability affects your stack