What’s Vulnerable › Vulnerabilities
CVE-2024-52357: WordPress LIQUID BLOCKS plugin <= 1.2.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in lqd LIQUID BLOCKS liquid-blocks allows Stored XSS.This issue affects LIQUID BLOCKS: from n/a through <= 1.2.0.
Affected products
- lqd LIQUID BLOCKS: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: lqd LIQUID BLOCKS 1.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52357 or the next vulnerability affects your stack