What’s Vulnerable › Vulnerabilities
CVE-2024-52389: WordPress WP Job Portal plugin <= 2.2.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpjobportal WP Job Portal wp-job-portal allows Stored XSS.This issue affects WP Job Portal: from n/a through <= 2.2.0.
Affected products
- wpjobportal WP Job Portal – AI-Powered Recruitment System for Company or Job Board website: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: wpjobportal WP Job Portal – AI-Powered Recruitment System for Company or Job Board website 2.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52389 or the next vulnerability affects your stack