What’s Vulnerable › Vulnerabilities
CVE-2024-5248: Improper Access Control in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-862
Description
In lunary-ai/lunary version 1.2.5, an improper access control vulnerability exists due to a missing permission check in the `GET /v1/users/me/org` endpoint. The platform's role definitions restrict the `Prompt Editor` role to prompt management and project viewing/listing capabilities, explicitly excluding access to user information. However, the endpoint fails to enforce this restriction, allowing users with the `Prompt Editor` role to access the full list of users in the organization. This vulnerability allows unauthorized access to sensitive user information, violating the intended access controls.
Affected products
- lunary-ai/lunary: from 1.2.5 before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/7f24ec1c3588992a07fd70573c43a0897eb523a2
- https://huntr.com/bounties/4ec75087-5630-4813-952b-88ccabe6d117
- https://huntr.com/bounties/4ec75087-5630-4813-952b-88ccabe6d117
Get alerted when CVE-2024-5248 or the next vulnerability affects your stack