What’s Vulnerable › Vulnerabilities
CVE-2024-52508: Nextcloud Mail auto configurator can be tricked into sending account information to wrong servers
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Nextcloud Mail is the mail app for Nextcloud, a self-hosted productivity platform. When a user is trying to set up a mail account with an email address like user@example.tld that does not support auto configuration, and an attacker managed to register autoconfig.tld, the used email details would be send to the server of the attacker. It is recommended that the Nextcloud Mail app is upgraded to 1.14.6, 1.15.4, 2.2.11, 3.6.3, 3.7.7 or 4.0.0.
Affected products
- nextcloud Mail: from 1.9.0 before 1.14.6; from 1.15.0 before 1.15.4; from 2.1.0 before 2.2.11; from 3.1.0 before 3.6.3; from 3.7.0 before 3.7.7 — fixed in 1.14.6, 1.15.4, 2.2.11, 3.6.3, 3.7.7
How to fix
Upgrade to a fixed version: nextcloud Mail 1.14.6, 1.15.4, 2.2.11, 3.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/mail/commit/a84c70e15d814dab6f0e8eda71bbaaf48152079b
- https://github.com/nextcloud/mail/pull/9964
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vmhx-hwph-q6mc
- https://hackerone.com/reports/2508422
Get alerted when CVE-2024-52508 or the next vulnerability affects your stack