What’s Vulnerable › Vulnerabilities
CVE-2024-52517: Nextcloud Server's global credentials of external storages are sent back to the frontend
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Nextcloud Server is a self hosted personal cloud system. After storing "Global credentials" on the server, the API returns them and adds them into the frontend again, allowing to read them in plain text when an attacker already has access to an active session of a user. It is recommended that the Nextcloud Server is upgraded to 28.0.11, 29.0.8 or 30.0.1 and Nextcloud Enterprise Server is upgraded to 25.0.13.13, 26.0.13.9, 27.1.11.9, 28.0.11, 29.0.8 or 30.0.1.
Affected products
- Nextcloud Server: from 25.0.0 before 25.0.13.13; from 26.0.0 before 26.0.13.9; from 27.0.0 before 27.1.11.9; from 28.0.0 before 28.0.11; from 29.0.0 before 29.0.8; from 30.0.0 before 30.0.1 — fixed in 25.0.13.13, 26.0.13.9, 27.1.11.9, 28.0.11, 29.0.8, 30.0.1
How to fix
Upgrade to a fixed version: Nextcloud Server 25.0.13.13, 26.0.13.9, 27.1.11.9, 28.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-x9q3-c7f8-3rcg
- https://github.com/nextcloud/server/commit/c45ed55f959ff54f3ea23dd2ae1a5868a075c9fe
- https://github.com/nextcloud/server/pull/48359
- https://hackerone.com/reports/2554079
Get alerted when CVE-2024-52517 or the next vulnerability affects your stack