What’s Vulnerable › Vulnerabilities
CVE-2024-52518: Nextcloud Server is missing password confirmation when changing external storage options
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-287
Description
Nextcloud Server is a self hosted personal cloud system. After an attacker got access to the session of a user or administrator, the attacker would be able to create, change or delete external storages without having to confirm the password. It is recommended that the Nextcloud Server is upgraded to 28.0.12, 29.0.9 or 30.0.2.
Affected products
- Nextcloud Server: from 28.0.0 before 28.0.12; from 29.0.0 before 29.0.9; from 30.0.0 before 30.0.2 — fixed in 28.0.12, 29.0.9, 30.0.2
How to fix
Upgrade to a fixed version: Nextcloud Server 28.0.12, 29.0.9, 30.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vrhf-532w-99rg
- https://github.com/nextcloud/server/pull/48373
- https://github.com/nextcloud/server/pull/48788
- https://github.com/nextcloud/server/pull/48992
- https://hackerone.com/reports/2602973
Get alerted when CVE-2024-52518 or the next vulnerability affects your stack