What’s Vulnerable › Vulnerabilities
CVE-2024-52525: Nextcloud Server User password is available in memory of the PHP process
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-312
Description
Nextcloud Server is a self hosted personal cloud system. Under certain conditions the password of a user was stored unencrypted in the session data. The session data is encrypted before being saved in the session storage (Redis or disk), but it would allow a malicious process that gains access to the memory of the PHP process, to get access to the cleartext password of the user. It is recommended that the Nextcloud Server is upgraded to 28.0.12, 29.0.9 or 30.0.2.
Affected products
- Nextcloud Server: from 28.0.0 before 28.0.12; from 29.0.0 before 29.0.9; from 30.0.0 before 30.0.2 — fixed in 28.0.12, 29.0.9, 30.0.2
How to fix
Upgrade to a fixed version: Nextcloud Server 28.0.12, 29.0.9, 30.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-w7v5-mgxm-v6gm
- https://github.com/nextcloud/server/commit/d25a0a2896a2a981939cacb8ee0d555feef22b3b
- https://github.com/nextcloud/server/pull/48915
Get alerted when CVE-2024-52525 or the next vulnerability affects your stack