What’s Vulnerable › Vulnerabilities
CVE-2024-5253: Ultimate Addons for WPBakery Page Builder <= 3.19.20 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultimate Addons for WPBakery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ult_team shortcode in all versions up to, and including, 3.19.20 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Brainstorm Force Ultimate Addons for WPBakery: before 3.19.20.1 — fixed in 3.19.20.1
How to fix
Upgrade to a fixed version: Brainstorm Force Ultimate Addons for WPBakery 3.19.20.1. Check the vendor advisory for mitigations.
References
- https://ultimate.brainstormforce.com/changelog/?utm_source=codecanyon-item-page&utm_campaign=uavc-changelog&utm_medium=changelog
- https://www.wordfence.com/threat-intel/vulnerabilities/id/97666e54-8e86-4f18-ae32-ad8ca607aeff?source=cve
- https://ultimate.brainstormforce.com/changelog/?utm_source=codecanyon-item-page&utm_campaign=uavc-changelog&utm_medium=changelog
- https://www.wordfence.com/threat-intel/vulnerabilities/id/97666e54-8e86-4f18-ae32-ad8ca607aeff?source=cve
Get alerted when CVE-2024-5253 or the next vulnerability affects your stack