What’s Vulnerable › Vulnerabilities
CVE-2024-52530
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-444
Description
GNOME libsoup before 3.6.0 allows HTTP request smuggling in some configurations because '\0' characters at the end of header names are ignored, i.e., a "Transfer-Encoding\0: chunked" header is treated the same as a "Transfer-Encoding: chunked" header.
Affected products
- GNOME libsoup: before 3.6.0 — fixed in 3.6.0
How to fix
Upgrade to a fixed version: GNOME libsoup 3.6.0. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libsoup/-/issues/377
- https://gitlab.gnome.org/GNOME/libsoup/-/merge_requests/402
- https://gitlab.gnome.org/Teams/Releng/security/-/wikis/home
- https://lists.debian.org/debian-lts-announce/2024/12/msg00014.html
Get alerted when CVE-2024-52530 or the next vulnerability affects your stack