What’s Vulnerable › Vulnerabilities
CVE-2024-52531
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-787
Description
GNOME libsoup before 3.6.1 allows a buffer overflow in applications that perform conversion to UTF-8 in soup_header_parse_param_list_strict. There is a plausible way to reach this remotely via soup_message_headers_get_content_type (e.g., an application may want to retrieve the content type of a request or response).
Affected products
- GNOME libsoup: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: GNOME libsoup 3.6.1. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libsoup/-/merge_requests/407
- https://gitlab.gnome.org/GNOME/libsoup/-/merge_requests/407#note_2316401
- https://gitlab.gnome.org/Teams/Releng/security/-/wikis/home
- https://offsec.almond.consulting/using-aflplusplus-on-bug-bounty-programs-an-example-with-gnome-libsoup.html
- https://lists.debian.org/debian-lts-announce/2024/12/msg00014.html
Get alerted when CVE-2024-52531 or the next vulnerability affects your stack